Exchange 2007 Installation

So this was kinda enlightening … the AD boys have setup for forest for me and schema / domain prepped too.

But when I went to Install Exchange I kept getting:

setup /mode:install /role:mt,mb,ca,ht

Welcome to Microsoft Exchange Server 2007 Unattended Setup

Preparing Exchange Setup

The following server roles will be installed
    Management Tools
    Hub Transport Role
    Client Access Role
    Mailbox Role

Performing Microsoft Exchange Server Prerequisite Check

    Organization Checks              ……………………. FAILED
     The Active Directory Schema must be modified and this user account has insufficient permissions. It must be a member of both the ‘Schema Admins’ and ‘Enterprise Admins’ groups.

     Global updates need to be made to Active Directory, and this user account is not a member of the ‘Enterprise Admins’ group.

     The local domain needs to be updated. You must be a member of the ‘Domain Admins’ and ‘Exchange Organization Administrators’ group, or ‘Enterprise Admins’ group to continue.

    Hub Transport Role Checks        ……………………. COMPLETED
 Setup cannot detect an SMTP or Send connector with an address space of ‘*’. Mail flow to the Internet may not work properly.
    Client Access Role Checks        ……………………. COMPLETED
    Mailbox Role Checks              ……………………. COMPLETED

The Exchange Server Setup operation did not complete. For more information, visit http://support.microsoft.com and enter the Error ID.

Exchange Server setup encountered an error.
 

WTF, i checked permissions and tried a milion and one different things before the penny dropped.  yeah you got it, the AD boys had use Exchange 2007 RTM and not SP1 ! … Doh!

The tell tail sign was the objectVersion on the Organization container in the Active Directory Configuration partition, it was set to 10666. 

After an SP1 forest prep I was still getting this:


setup /mode:install /role:mt,ca,ht,mb

Welcome to Microsoft Exchange Server 2007 Unattended Setup

Preparing Exchange Setup

The following server roles will be installed
    Management Tools
    Hub Transport Role
    Client Access Role
    Mailbox Role

Performing Microsoft Exchange Server Prerequisite Check

    Organization Checks              ……………………. FAILED
     Global updates need to be made to Active Directory, and this user account is not a member of the ‘Enterprise Admins’ group.

     The local domain needs to be updated. You must be a member of the ‘Domain Admins’ and ‘Exchange Organization Administrators’ group, or ‘Enterprise Admins’group to continue.

    Hub Transport Role Checks        ……………………. COMPLETED
 Setup cannot detect an SMTP or Send connector with an address space of ‘*’. Mail flow to the Internet may not work properly.
    Client Access Role Checks        ……………………. COMPLETED
    Mailbox Role Checks              ……………………. COMPLETED

The Exchange Server Setup operation did not complete. For more information, visit http://support.microsoft.com and enter the Error ID.

Exchange Server setup encountered an error.

Intersting, the objectVersion didn’t change to 11221 until the domain prep was run?!

Check this out for info on the objectVersion

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: