New-MoveRequest Fails at 95%

#Exchange2010 #Exchange

I had a single mailbox, that I could not move from Exchange 2003 to Exchange 2010.  It moved from 2003 to another 2003 database no problem, but 2003 to 2010 no chance.

From the MoveRequest Log you could see this at the end:

12/10/2011 1:04:36 AM [CAS] Fatal error UpdateMovedMailboxPermanentException has occurred.
Error details: An error occurred while updating a user object after the move operation. –> Active Directory operation failed on MyDC. One or more attribute entries of the object ‘BadUser’ already exists. –> The attribute exists or the value has been assigned.
   at Microsoft.Exchange.MailboxReplicationService.LocalMailbox.Microsoft.Exchange.MailboxReplicationService.IMailbox.UpdateMovedMailbox(UpdateMovedMailboxOperation op, ADUser remoteRecipientData, String domainController, ReportEntry[]& entries, Guid newDatabaseGuid, Guid newArchiveDatabaseGuid, String archiveDomain, ArchiveStatusFlags archiveStatus)
   at Microsoft.Exchange.MailboxReplicationService.MailboxWrapper.<>c__DisplayClass3c.<Microsoft.Exchange.MailboxReplicationService.IMailbox.UpdateMovedMailbox>b__3b()
   at Microsoft.Exchange.MailboxReplicationService.ExecutionContext.Execute(GenericCallDelegate operation)
   at Microsoft.Exchange.MailboxReplicationService.MailboxWrapper.Microsoft.Exchange.MailboxReplicationService.IMailbox.UpdateMovedMailbox(UpdateMovedMailboxOperation op, ADUser remoteRecipientData, String domainController, ReportEntry[]& entries, Guid newDatabaseGuid, Guid newArchiveDatabaseGuid, String archiveDomain, ArchiveStatusFlags archiveStatus)
   at Microsoft.Exchange.MailboxReplicationService.LocalMoveJob.UpdateMovedMailbox()
   at Microsoft.Exchange.MailboxReplicationService.MoveBaseJob.UpdateAD(Object[] wiParams)
   at Microsoft.Exchange.MailboxReplicationService.CommonUtils.CatchKnownExceptions(GenericCallDelegate del, FailureDelegate failureDelegate)
Error context: ——–
Operation: IMailbox.UpdateMovedMailbox
OperationSide: Target
Primary (62d90226-d9a1-4941-baa5-28104b5fab78)
12/10/2011 1:04:36 AM [CAS] Relinquishing job.

It turns out that in when looking in the AD at the user proxy addresses a couple of them had an Š instead of an S.

When you looked with Exchange, it showed the S and not Š

So it’s an extended ASCII character (_http://en.wikipedia.org/wiki/%C5%A0 (_http://en.wikipedia.org/wiki/%C5%A0)). 

When I have changed it to a “normal” S using ADSIEdit, the move then worked!

How funky! .. Interesting in the Get-Mailbox still tagged the mailbox as valid!

Virus of the week (2012-01-09)

#Exchange #Exchange2010 #Virus

So this is a summary of what Microsoft Forefront Protection for Exchange Server detected as a virus.

Trojan-Spy.HTML.Fraud.gen

  • Subject line:  "Botanical Gardens Boot Camp NOW STARTING"
  • Subject line:  "Just for Cardholders: Save an extra 10% on select TVs at Amazon.com"
  • Subject line:  "Bank of America Customer Service – Tell us what you think"
  • Subject line:  "PayPal – Your account has been limited!"

Win32/Pdfjsc.RF

MSWord/Dropper.B!Camelot   

  • File name:  "winmail.dat->Insurance.zip->1036775_4909136e-c76f-466a-a8fe-a935fb735dbd_TATAAIGFIRSTPLAN.doc"